Перейти к контенту

Recommended Posts

Ошибка импорта PCAD ASCII из Алтиум. Раньше не бьйли такие, первой раз вижу. 

Версия Топора: 6.1.4.16354ru и 6016118ru. 

Версия Алтиум: 15.1.12 Build 45129 Update 1

 

Ошибка: При чтении файла возникла критическая ошибка "end of file".

 

Качаю файлов, но не могу качать .pcbdoc - размер превьйшает допустимой, а плата у меня вообще маленкая.

1. Администраторы пожалуйста увеличите лимита файлов!

2. Не могу качать 100кб JPG файл скрийншот с ошибки, непонятно почему.

6B-QT PCB.rar

Share this post


Link to post
Share on other sites

Ошибка импорта PCAD ASCII из Алтиум. Раньше не бьйли такие, первой раз вижу. 

Версия Топора: 6.1.4.16354ru и 6016118ru. 

Версия Алтиум: 15.1.12 Build 45129 Update 1

 

Ошибка: При чтении файла возникла критическая ошибка "end of file".

 

Качаю файлов, но не могу качать .pcbdoc - размер превьйшает допустимой, а плата у меня вообще маленкая.

1. Администраторы пожалуйста увеличите лимита файлов!

2. Не могу качать 100кб JPG файл скрийншот с ошибки, непонятно почему.

Причина ошибки - вот тут 

(text (pt -2.486mm 0.562mm) "G

" (textStyleRef "T:H39W8") (rotation 360.0) )

По-видимому, эта строчка разбита на две ВРУЧНУЮ. Если их соединить обратно 

(text (pt -2.486mm 0.562mm) "G" (textStyleRef "T:H39W8") (rotation 360.0) )

то всё будет хорошо.

  • Like 1

Share this post


Link to post
Share on other sites

Да, я так и думал, спасибо! 

 

Оказалось, проблем произошел от сломанной футпринт из библиотеки Альтиума.

Исправил футпринта (сгенерировал новьй и записал под тоже самое имя) и все теперь в порядки - Топор импортирует нормально.

 

А с какой текстовой редактор вьй посмотрели етого стринга?

Share this post


Link to post
Share on other sites

Смотрели через Блокнот (Notepad). Но можно вообще через любой, лишь бы он позволял открыть файл с данным расширением. А если не позволяет - переименовать файл в *.txt, потом посмотреть, поправить и переименовать обратно ;-)

Share this post


Link to post
Share on other sites

Ребят, всем доброго времени суток!

 

Вот с такой проблемой столкнулся: получилось на плате неудобное расположение деталей (на картинке цепи Net@11 и Net@15). Т.к. эти сети подключены к обмотке неполярного реле, то всего-то надо поменять их местами. То есть к ноге 2 реле подключить Net@15 вместо Net@11, а к ноге 3 - Net@11 вместо Net@15.

 

 

Делал так:

1. Экспорт в ToporPCB

2. В текстовом редакторе для цепей Net@11 и Net@15 поправил назначение ног 2 и 3 для компонента K2 (собственно реле)

3. Импортирую и вижу глюк: цепь Net@11 почему-то соединена сразу и с ногой 2 и с ногой 3 компонента К2 (а должна быть соединена только с ногой 3)

 

Тупил пару часов, но так и не въехал что я делаю не так... Похоже это глюк импорта, но почему???

 

P.S. Прилагаю картинки до и после исправления, а так же экспорт Topor PCB до исправления и после:

https://cloud.mail.ru/public/4xC2/qnMEqqRfF

На облако выложил, т.к. к сообщению больше 500кБ не прицепляется.

Share this post


Link to post
Share on other sites

Вы все сделали правильно, но неправильно поняли увиденное на экране.

Вы переназначили цепи, но проводник не удалили (сообщение об ошибке имеется), то есть проводник находится на чужом контакте (2) и показывается связь проводника с контактом 3, поскольку проводник не доведен до контакта.

Одновременно показывается связь контакта 2 с контактом 1 компонента U3, и создается впечатление, что соединяются различные цепи.

Если конец проводника цепи Net@11 "снять" с контакта 2, то Вы увидите реальную правильную картину.

 

post-58-0-69525100-1436951128_thumb.jpg

Share this post


Link to post
Share on other sites

Вот такая незадача. После трассировки и открытии в редакторе крашится топор

Windows 10

Topor Lite 6.1.4.16540

 

1) Импортировался Spektra дизайн (KiCad 4.0.0-rc2)

2) Автотрассировка как есть (небольшие подвижки компонентов)

3) по завершении трассировки открыть в редакторе

4) краш

 

Проект TopoR, а так же Spektra DSN из которого импортировалась + дамп процесса после краша, 27метров

 

https://www.dropbox.com/s/xlovv85qbjn2dgl/crash.7z

Share this post


Link to post
Share on other sites

Вот такая незадача. После трассировки и открытии в редакторе крашится топор

Windows 10

Topor Lite 6.1.4.16540

 

1) Импортировался Spektra дизайн (KiCad 4.0.0-rc2)

2) Автотрассировка как есть (небольшие подвижки компонентов)

3) по завершении трассировки открыть в редакторе

4) краш

 

Проект TopoR, а так же Spektra DSN из которого импортировалась + дамп процесса после краша, 27метров

 

https://www.dropbox.com/s/xlovv85qbjn2dgl/crash.7z

Спасибо за сообщение, ошибку исправили. А пока Вы можете поменять нижнему слою тип на сигнальный. Тогда эта ошибка не будет проявляться.

  • Like 1

Share this post


Link to post
Share on other sites

 

Вот такая незадача. После трассировки и открытии в редакторе крашится топор

Спасибо за сообщение, ошибку исправили. А пока Вы можете поменять нижнему слою тип на сигнальный. Тогда эта ошибка не будет проявляться.

 

 

Спасибо, очень оперативно!

Спасибо огромное за workaround

Share this post


Link to post
Share on other sites
TopoR Lite 6.2.16891  (x64)

Windows 7.

Foxit Reader PDF Priter.

 

Проблема:

Печатает пустой лист с включенной галочкой "Зеркальное изображение".

 

Со снятой галочкой печатает как положено  :mellow:

 

Сейчас печатаю через Gerber файл :wacko2: Пожалуйста, почините любимый трассировщик.

Share this post


Link to post
Share on other sites

Проблема:

Печатает пустой лист с включенной галочкой "Зеркальное изображение".

 

​Проблема подтвердилась при работе с Foxit Reader версии 6.*

С Foxit Reader 7.2 проблемы нет. Обновите пожалуйста Foxit Reader.

Share this post


Link to post
Share on other sites

Здравствуйте. Следующая проблема - Win XP x64, TopoR Lite 6.2.16896 x64, импорт из Eagle 7.5.0

Результатом авторазводки, при указании разводить только нижним слоем, является плохоразведённая, либо разведённая плата, с кучей "Ошибка 5027! На слое 'BOTTOM' проводник цепи 'N$1' пересекает контакт PAD4-1 (цепь 'N$1'). Для всех площадок и дорожек. Авторазводка на 2 слоя часто даёт такой же результат, но без ошибок.

 

Исходный brd(в архиве, не хочет форум прикреплять его просто так) и fsx с ошибками.

 

Версия 6.1.4.16540 в таком поведении не замечена.

untitled_38-0s_error.fsx

untitled.zip

Изменено пользователем phoenix1917

Share this post


Link to post
Share on other sites

Здравствуйте. Следующая проблема - Win XP x64, TopoR Lite 6.2.16896 x64, импорт из Eagle 7.5.0

Результатом авторазводки, при указании разводить только нижним слоем, является плохоразведённая, либо разведённая плата, с кучей "Ошибка 5027! На слое 'BOTTOM' проводник цепи 'N$1' пересекает контакт PAD4-1 (цепь 'N$1'). Для всех площадок и дорожек. Авторазводка на 2 слоя часто даёт такой же результат, но без ошибок.

 

Исходный brd(в архиве, не хочет форум прикреплять его просто так) и fsx с ошибками.

 

Версия 6.1.4.16540 в таком поведении не замечена.

Добрый день!

Ваши ошибка исправлена, спасибо за сообщение. Исправление войдет в следующую сборку.

Share this post


Link to post
Share on other sites

Версии TopoR_LiteRu_6216901_x86 и TopoR_LiteRu_6216901_x64 на компьютер с Windows10 не устанавливаются.

Пишет:

Это приложение заблокировано в целях защиты

Издатель: нет доверия.

Share this post


Link to post
Share on other sites

Версии TopoR_LiteRu_6216901_x86 и TopoR_LiteRu_6216901_x64 на компьютер с Windows10 не устанавливаются.

Пишет:

Это приложение заблокировано в целях защиты

Издатель: нет доверия.

Старый сертификат отозван, поэтому версия сейчас не устанавливается. Новая версия будет собрана и выложена с новым сертификатом, и эта проблема уйдет.

Share this post


Link to post
Share on other sites

Сегодня скачал и установил триальную версию TopoR 6.2 8L Trial x64, при запуске выдает "Пробный период истек" Это как-то решается?

Действительно, имела место диверсия. Сейчас ошибка исправлена, можно качать-ставить-пользовать.

Share this post


Link to post
Share on other sites

post-199-0-25497500-1459552257_thumb.jpg

Поставил TopoR_2LayRu_6216946_x86 - установился, но ругается при запуске. Говорит не вижу ключа.

Драйвер Guardant (Stealth II) стоит, ключ опознается.  

win xp sp3

?

Вопрос прояснен: "Начиная с версии 6.2 поддержка ключей Guardant Stealth II прекращена"

Share this post


Link to post
Share on other sites

attachicon.gifs1.jpg

Поставил TopoR_2LayRu_6216946_x86 - установился, но ругается при запуске. Говорит не вижу ключа.

Драйвер Guardant (Stealth II) стоит, ключ опознается.  

win xp sp3

?

Вопрос прояснен: "Начиная с версии 6.2 поддержка ключей Guardant Stealth II прекращена"

После сноса версии 6.2

пытался установить обратно 6.1

Теперь и она упорно не хочет видеть ключ.

Чистил реестр и папки.

В диспетчере устройств ключ виден. Родной утилитой распознается (тип, серийный номер)

Share this post


Link to post
Share on other sites

 

attachicon.gifs1.jpg

Поставил TopoR_2LayRu_6216946_x86 - установился, но ругается при запуске. Говорит не вижу ключа.

Драйвер Guardant (Stealth II) стоит, ключ опознается.  

win xp sp3

?

Вопрос прояснен: "Начиная с версии 6.2 поддержка ключей Guardant Stealth II прекращена"

После сноса версии 6.2

пытался установить обратно 6.1

Теперь и она упорно не хочет видеть ключ.

Чистил реестр и папки.

В диспетчере устройств ключ виден. Родной утилитой распознается (тип, серийный номер)

 

В ночи провел эксперимент на другом компьютере.

Начал с 6016118

Работает.

Поверху поставил  последнюю 6116540.

Работает.

Дальше пресловутую 6216946_x86.

Ожидаемо ругается.

Поверху поставил предыдущую 6116540.

Ругается.

Деинсталлировал и снова поставил  6116540.

Работает.

Что-то он на моем компе при переустановке  похоже поломал. :sad:

Драйверы брелка при деинсталляции, и vc++ не удаляются. 

Share this post


Link to post
Share on other sites

 

Вопрос прояснен: "Начиная с версии 6.2 поддержка ключей Guardant Stealth II прекращена"

Начиная с версии 6.2 изменена система защиты. Все пользователи, у которых продолжается годовая поддержка получили сообщения о новой версии и о том, что для ее работы следует обратиться за получением нового ключа. Если Ваш срок годовой поддержки еще не истек, но Вы не получили письма, можете написать мне на почту: vorobyeva.ov@spb.prosoft.ru 

Мы проверим, какие проблемы возникают при установке 6.1 поверх версии 6.2.

Share this post


Link to post
Share on other sites

Тщательная чистка с перустановкой Windows installer-a (внезапно отказавшего), решила проблему.  

 

 

attachicon.gifs1.jpg

Поставил TopoR_2LayRu_6216946_x86 - установился, но ругается при запуске. Говорит не вижу ключа.

Драйвер Guardant (Stealth II) стоит, ключ опознается.  

win xp sp3

?

Вопрос прояснен: "Начиная с версии 6.2 поддержка ключей Guardant Stealth II прекращена"

После сноса версии 6.2

пытался установить обратно 6.1

Теперь и она упорно не хочет видеть ключ.

Чистил реестр и папки.

В диспетчере устройств ключ виден. Родной утилитой распознается (тип, серийный номер)

 

В ночи провел эксперимент на другом компьютере.

Начал с 6016118

Работает.

Поверху поставил  последнюю 6116540.

Работает.

Дальше пресловутую 6216946_x86.

Ожидаемо ругается.

Поверху поставил предыдущую 6116540.

Ругается.

Деинсталлировал и снова поставил  6116540.

Работает.

Что-то он на моем компе при переустановке  похоже поломал. :sad:

Драйверы брелка при деинсталляции, и vc++ не удаляются. 

 

 

Share this post


Link to post
Share on other sites

 

Тщательная чистка с перустановкой Windows installer-a (внезапно отказавшего), решила проблему.  

 

Соблюдение гигиены способствует, да ))

Share this post


Link to post
Share on other sites

Создайте аккаунт или авторизуйтесь, чтобы оставить комментарий

Комментарии могут оставлять только зарегистрированные пользователи

Создать аккаунт

Зарегистрировать новый аккаунт в нашем сообществе. Это несложно!

Зарегистрировать новый аккаунт

Войти

Есть аккаунт? Войти.

Войти

×