Перейти к контенту
orthodox

Обратная связь по работе SimOne

Recommended Posts

orthodox    0

Собственно, эта тема на случай, если ведется активная работа над проектом. Вроде как заявлено, что в самом движке будут преимущества, для точности и скорости, а это всегда интересно. Так что наверное есть смысл начинать пробовать и отписываться о том, что поправить, глючки там всякие, то да се... Заинтересованные пользователи - лучшие тестеры, так - нет? Щас вот попробую заставить его простую RC цепочку симулировать, после уже можно чего-то сравнивать и отписывать... Кстати, а отчего там соединения незалитыми точками отображаются? Это можно как-то поменять? Ага, вот еще. В редакторе проблемка: «хвостики», огрызки проводников, что в пределах одного шага сетки длиной на выводах элементов практически неуправляемы, и норовят присвоить себе какой попало номер цепи. Удалить эти обрезки не получилось. Кстати, если выводы элементов соединять одной линией поперек , например, при выставлении их в ряд и соединяя с землей - то точка соединения не проставляется. Ну и двигать проводники возле выводов неудобно - норовистые становятся очень.

Share this post


Link to post
Share on other sites
AlexPrikota    1

Работа ведется и очень активная! Скоро новая версия. Глюков и багов пока хватает, к сожалению....вылавливаем как можем. В том числе в редакторе. Заливку соединений сейчас настроить нельзя - к след. версии подготовим.Там же отловим и глюки с соединениями.

Share this post


Link to post
Share on other sites
orthodox    0
Работа ведется и очень активная! Скоро новая версия. Глюков и багов пока хватает, к сожалению....вылавливаем как можем. В том числе в редакторе. Заливку соединений сейчас настроить нельзя - к след. версии подготовим.Там же отловим и глюки с соединениями.
Ладно, тогда, раз уже и так есть фронт работ, подожду следующей версии, а тогда активно подключусь к тестированию.

Share this post


Link to post
Share on other sites

1. Нет удобных инструментов масштабирования графика, например, колёсиком мыши. После выделения на графике фрагмента для увеличения сделать изображение мельче уже нельзя: можно либо перестроить график, запустив заново симуляцию, либо вернуться к исходному размеру, выделив произвольный фрагмент рамкой движением влево вверх (это совсем не очевидный приём).

2. У графопостроителя нет привычных традиционных курсоров. Измерить значения величин, а также разницу между ними и т.п. в произвольной точке графика нельзя.

3. В окне построения схемы рабочий стол можно двигать при нажатой правой кнопке мыши. Хотелось бы, чтобы то же самое можно было делать при нажатом колёсике, как это сделано, например в "Компасе" - и масштабирование, и перемещение рабочего листа осуществляется колёсиком.

4. Параметры компонентов, например, для катушки L, R, Tolerance, и т.д. не стоит выводить в интерфейс в том виде, в котором они присутствуют в Спайсе. Пользователь не обязан знать значение внутренних аббревиатур спайса, поэтому по крайней мере основные параметры лучше записать в более понятном виде: Индуктивность, Внутреннее сопротивление, Точность % и т.д.

5. Потенциалы узлов и токи лучше отображать в виде 12кВ, 12МВ вместо вида 1,2e4, 1,2e7

6. После того, как я при первом запуске программы открыл окошко параметром симуляции и ненароком сдвинул его за пределы рабочей области, оно исчезло бесследно и больше его вызвать никак не удаётся, даже после переустановки программы.

7. После первого запуска симуляции становится невозможным редактировать схему: компоненты и цепи не двигаются, двойным щелчком открыть свойства компонента тоже нельзя при нажатии появляется всплывающее меню с двумя пунктами, например:

I(C11)

V(C11)

Выбор любого пункта ни к чему не ведёт. Этот ступор проходит если добавить на схему какой-нибудь новый компонент.

Share this post


Link to post
Share on other sites
AlexPrikota    1

В бижайшее время (через неделю-полторы) выдет полное руководство пользователя SimOne. Там будут все описания и пояснения, так что многие вопросы отпадут. Ну а пока по-порядку:

1. Масштабирование графика. Приближение - выделенем заданной области рамкой при нажатой левой кнопи мыши. Возврат исходного масштаба - перемещение курсора мышки с правого нижнего угла в левый верхний при нажатой левой кнопи мыши. Вполне удобно. Впрочем на вкус и цвет...

Масштабирование колесиком мыши в процессе добавления.

2. Неправда. Курсоры были добавлены еще в версии SimOne 1.2.0 (http://eda.eremex.ru/support/history_simone.html), кнопки курсоров на панели добавлены в текущей версии SimOne 1.2.1 (http://eda.eremex.ru/news/464947.html). Включаются либо из основного меню График->Курсоры, либо кнопной на панели. Координаты и измерения курсоров отображаются в соответствующем окне "Значения курсоров"

3.,4.,5. - подумаем

6.В ближайшей версии добавим кнопку возврата настроек программы по умолчанию в окно "Настроки" (Инструменты->Настройки). А пока можно вручную удалить файл настроек из C:\Documents and Settings\Application Data\Eremex\SimOne\SimOne.cfg

7. Это происходит потому что программа находится в режиме задания параметров Симуляции (при открытом окне "Симуляция") По щелчку на компоненте появляется вспывающее меню с выбором переменных(V или I ) для расчета. Это не ступор.

Чтобы вернуться к редактированию схемы надо закрыть окно "Симуляция".

Share this post


Link to post
Share on other sites

1. Возврат исходного масштаба рамкой - да, в целом нормально, но такой способ редко практикуется, он не очевиден.

2. "Включаются либо из основного меню График->Курсоры" - да, так получилось. При установке кнопки курсоров, если не ошибаюсь, не было на панели.

6. Да, после удаления SimOne.cfg окошко настроек симуляции открывается нормально.

7. Хорошая возможность - оценил, когда окошко настроек симуляции стало отображаться.

Share this post


Link to post
Share on other sites
mshepelev    0

Беда...

Шла тут речь про MOSFET - так они в библиотеке есть,но как до симуляции - так сразу "шаг вычислений уменьшен до нуля!", и adios.

А с тиристорами и симисторами еще круче - при попытке вставить их в схему SimOne просто вылетает.

Это баги такие или надо просто подождать?

Share this post


Link to post
Share on other sites
AlexPrikota    1

С тиристорами и симисторами а также некоторыми сложными компонентами из Базы данных такая проблема есть - программа зависает при попытке поставить их на схему. У нас она уже решена, правка появится в ближайшем обновлении.

С Мосфетами: проблемы со сходимостью возможны (впрочем как и у других). Возможны, конечно, и ошибки в расчете параметров моделей.

Можно прислать пример такой схемы?.

Share this post


Link to post
Share on other sites
mshepelev    0

Dear Alex!

Я полагаю, Вы один из разработчиков, а также мне кажется, именно Вы показывали мне на выставке работу SimOne.

Вот дождался я выхода версии 1.4. Не скажу, что ничего не изменилось - теперь с MOSFETами симуляция запускается, и шаг до нуля не уменьшается, но зато процесс не заканчивается никогда.

С тиристорами тоже очевидный прогресс - теперь они благополучно вставляются. Но определить, где анод, где катод, а где УЭ, можно только экспериментально. Мне кажется, я правильно определил...

Включил - и мгновенно "шаг уменьшен до нуля", никакого графика, естественно.

Вот я и гадаю - это я такой тупой, что все неправильно делаю (а до этого в PSpise4, Design Center и DesignLab, а тако же в MicroCAP много лет все прокатывало), или все-таки что-то неладно в SimOne.

Конечно, я могу в новом учебном году снова построить учебный курс на импортных продуктах, но хотелось бы, чтобы студенты наше, российское, изучали и применяли.

Уж не сочтите за труд, подскажите, что делать.

Share this post


Link to post
Share on other sites
AlexPrikota    1

Добрый день!

В версии 1.4 MOSFETами не занимались. Работали над другими проблемами - БПФ, сходимость расчета рабочей точки, функциии курсоров, экспорт уравнений и проч.... основные изменения и новые возможности указаны в анонсе версии на сайте.

Сейчас стабильно и устойчиво считаются биполярные, полевые, арсенид-галлиевые транзисторы. MOSFETы постараемся починить в следующем обновлении, ориентировочно - в августе.

В базе готовых моделей тоже многое поправили... но проблемы еще остаются; неполное отображение УГО тиристора( неуказаны анод и катод) также посмотрим и поправим.

SimOne сейчас находится на стадии активного бета-тестирования, и мы надеемся в скорое время выпустить устойчивую релизную версию.

Share this post


Link to post
Share on other sites
DNefedov    0

Добрый день.

 

Хотелось бы сообщить об ошибке: транзистор 2П305А_Б из базы отечественных компонентов имеет неправильный параметр W (ширина проводящего канала, указанное значение близко к 1 километру). Также стоит отметить, что в реальной жизни 2П305 имеет вывод "корпус-подложка".

 

Быть может стоит завести какое-то подобие багтрекера для таких вещей?

Share this post


Link to post
Share on other sites
AlexPrikota    1

Добрый день.

 

Хотелось бы сообщить об ошибке: транзистор 2П305А_Б из базы отечественных компонентов имеет неправильный параметр W (ширина проводящего канала, указанное значение близко к 1 километру). Также стоит отметить, что в реальной жизни 2П305 имеет вывод "корпус-подложка".

 

Быть может стоит завести какое-то подобие багтрекера для таких вещей?

Спасибо за сообщение, действительно ошибка и в ширине канала и в количестве выводов транзистора. В ближаешее время исправим.

И насчет багтрекера подумаем ).

Share this post


Link to post
Share on other sites
AlexPrikota    1

SimOne 2.0 beta, в отличии от предыдущих версий, не является приложением win32?!

Под Win7,Win8 такой проблемы не должно быть. У Вас WinXP?.

Share this post


Link to post
Share on other sites
test4    1

 

SimOne 2.0 beta, в отличии от предыдущих версий, не является приложением win32?!

Под Win7,Win8 такой проблемы не должно быть. У Вас WinXP?.

 

Да, WInXP.  Еще и предыдущие версии 1.6beta перестали работать после установки версии 2.0.

Share this post


Link to post
Share on other sites
AlexPrikota    1

 

 

SimOne 2.0 beta, в отличии от предыдущих версий, не является приложением win32?!

Под Win7,Win8 такой проблемы не должно быть. У Вас WinXP?.

 

Да, WInXP.  Еще и предыдущие версии 1.6beta перестали работать после установки версии 2.0.

 

Вложили новую сборку 2.0.15093. Все должно работать. )

Share this post


Link to post
Share on other sites
test4    1

Сборка 2.0.15093. на WinXp  заработала.  Выложите пожалуйста примеры, демонстрирующиеся на вебинаре.  При загрузке из базы компонентов Opamp  MCP6021  появляется сообщение об ошибке.

post-168-0-31656700-1386047780_thumb.png

Share this post


Link to post
Share on other sites
test4    1

Ошибка во временном анализе (видимо и в других тоже)  при наличии в схеме компонента,  загруженного из текстового файла. Что интересно, если эту  схему экспортировать в spice-нетлист и запустить на временной анализ, то все считается без ошибок.  Тестируемую схему, нетлист, модель компонента прилагаю.

LQH.zip

Share this post


Link to post
Share on other sites
AlexPrikota    1

Ошибка во временном анализе (видимо и в других тоже)  при наличии в схеме компонента,  загруженного из текстового файла. Что интересно, если эту  схему экспортировать в spice-нетлист и запустить на временной анализ, то все считается без ошибок.  Тестируемую схему, нетлист, модель компонента прилагаю.

Да, это ошибка. Может возникать как раз при чтении модели из текстового файла. Исправим к следующей сборке. Спасибо.

Share this post


Link to post
Share on other sites
AlexPrikota    1

Сборка 2.0.15093. на WinXp  заработала.  Выложите пожалуйста примеры, демонстрирующиеся на вебинаре.  При загрузке из базы компонентов Opamp  MCP6021  появляется сообщение об ошибке.

Базу компонентов поправим к следующей сборке,  там нашлись еще некоторые ошибки в описании моделей.

Примеры с вебинара прилагаю.

Webinar Samples.zip

Share this post


Link to post
Share on other sites
mshepelev    0

 

 

 

SimOne 2.0 beta, в отличии от предыдущих версий, не является приложением win32?!

Под Win7,Win8 такой проблемы не должно быть. У Вас WinXP?.

 

Да, WInXP.  Еще и предыдущие версии 1.6beta перестали работать после установки версии 2.0.

 

Вложили новую сборку 2.0.15093. Все должно работать. )

 

Здравствуйте, уважаемый Alex!

У меня XP.

Не далее чем сегодня утром скачал сборку 2.0.15093, чин чином инсталлировал, а когда дошло до дела -

 

"Failed to load library C:\ProgramFiles\SimOne\bin\credll.dll. Приложение не было запущено, поскольку оно некорректно настроено. Повторная установка приложения может решить данную проблему".

 

Не смогла...

 

Жду Вашего просвещенного мнения.

Share this post


Link to post
Share on other sites

Создайте аккаунт или авторизуйтесь, чтобы оставить комментарий

Комментарии могут оставлять только зарегистрированные пользователи

Создать аккаунт

Зарегистрировать новый аккаунт в нашем сообществе. Это несложно!

Зарегистрировать новый аккаунт

Войти

Есть аккаунт? Войти.

Войти

×